using non-free radeon firmware with a libre kernel base

Christopher Howard christopher.howard at
Fri Apr 19 14:52:26 UTC 2013

I imagine that subject line will get me booted from this list, but I'm
stuck between a rock and hardplace. I want OpenGL support (and
eventually OpenCL). /Every/ single Radeon card requires non-free
firmware. What else can I do?

I wanted to use the libre kernel as a base, though, so I didn't get a
whole bunch of other non-free stuff included. I've done everything I
think needs to be done to get this to work:

1. Installed radeon-ucode into /lib/firmware/radeon through a distro

2. Set config:

CONFIG_EXTRA_FIRMWARE="radeon/ARUBA_me.bin radeon/ARUBA_pfp.bin
radeon/ARUBA_rlc.bin radeon/BARTS_mc.bin radeon/BARTS_me.bin
radeon/BARTS_pfp.bin radeon/BTC_rlc.bin radeon/CAICOS_mc.bin
radeon/CAICOS_me.bin radeon/CAICOS_pfp.bin radeon/CAYMAN_mc.bin
radeon/CAYMAN_me.bin radeon/CAYMAN_pfp.bin radeon/CAYMAN_rlc.bin
radeon/CEDAR_me.bin radeon/CEDAR_pfp.bin radeon/CEDAR_rlc.bin
radeon/CYPRESS_me.bin radeon/CYPRESS_pfp.bin radeon/CYPRESS_rlc.bin
radeon/CYPRESS_uvd.bin radeon/JUNIPER_me.bin radeon/JUNIPER_pfp.bin
radeon/JUNIPER_rlc.bin radeon/OLAND_ce.bin radeon/OLAND_mc.bin
radeon/OLAND_me.bin radeon/OLAND_pfp.bin radeon/OLAND_rlc.bin
radeon/PALM_me.bin radeon/PALM_pfp.bin radeon/PITCAIRN_ce.bin
radeon/PITCAIRN_mc.bin radeon/PITCAIRN_me.bin radeon/PITCAIRN_pfp.bin
radeon/PITCAIRN_rlc.bin radeon/R100_cp.bin radeon/R200_cp.bin
radeon/R300_cp.bin radeon/R420_cp.bin radeon/R520_cp.bin
radeon/R600_me.bin radeon/R600_pfp.bin radeon/R600_rlc.bin
radeon/R700_rlc.bin radeon/REDWOOD_me.bin radeon/REDWOOD_pfp.bin
radeon/REDWOOD_rlc.bin radeon/RS600_cp.bin radeon/RS690_cp.bin
radeon/RS780_me.bin radeon/RS780_pfp.bin radeon/RV610_me.bin
radeon/RV610_pfp.bin radeon/RV620_me.bin radeon/RV620_pfp.bin
radeon/RV630_me.bin radeon/RV630_pfp.bin radeon/RV635_me.bin
radeon/RV635_pfp.bin radeon/RV670_me.bin radeon/RV670_pfp.bin
radeon/RV710_me.bin radeon/RV710_pfp.bin radeon/RV710_uvd.bin
radeon/RV730_me.bin radeon/RV730_pfp.bin radeon/RV770_me.bin
radeon/RV770_pfp.bin radeon/RV770_uvd.bin radeon/SUMO2_me.bin
radeon/SUMO2_pfp.bin radeon/SUMO_me.bin radeon/SUMO_pfp.bin
radeon/SUMO_rlc.bin radeon/SUMO_uvd.bin radeon/TAHITI_ce.bin
radeon/TAHITI_mc.bin radeon/TAHITI_me.bin radeon/TAHITI_pfp.bin
radeon/TAHITI_rlc.bin radeon/TAHITI_uvd.bin radeon/TURKS_mc.bin
radeon/TURKS_me.bin radeon/TURKS_pfp.bin radeon/VERDE_ce.bin
radeon/VERDE_mc.bin radeon/VERDE_me.bin radeon/VERDE_pfp.bin

I can see these firmwares being built when I run Make. Yet, I still get
this error:

[   25.802779] [drm] Setting GART location based on new memory map
[   25.803386] [drm] Loading RS780 CP Microcode
[   25.803392] r600_cp.0: Missing Free firmware
[   25.806729] [drm:r600_do_init_cp] *ERROR* Failed to load firmware!

In summary, I was wondering if libre adjustments to the kernel do
anything else to the configuration that I need to fix in order for this
to work.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 555 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the linux-libre mailing list